-4
Використовувати лише IPv4.
-6
Використовувати лише IPv6.
-a
Звуковий луна-імпульс.
-A
Адаптивне зондування. Інтервал між пакетами адаптується до часу проходження сигналу так, щоб у мережі одночасно було не більше одного (або більшої кількості, якщо встановлено попереднє завантаження) зондування без відповіді. Мінімальний інтервал складає 200 мілісекунди, якщо програму не запущено від імені надкористувача. У мережах із низьким часом проходження сигналу (RTT) цей режим є по суті еквівалентом режим заповнення.
-b
Дозволити зондування адреси трансляції.
-B
Не дозволяти ping змінювати адресу джерела зондувань. Адресу буде пов'язано із вибраною на момент запуску ping.
-c кількість
Зупинитися після надсилання кількості пакетів ECHO_REQUEST. Із параметром строк_дії ping очікує на кількість пакетів ECHO_REPLY, аж доки завершиться час очікування.
-C
Викликати системну функцію connect() при створенні сокета.
-d
Встановити параметр SO_DEBUG для використано сокета. Насправді, цей параметр сокета не використовується ядром Linux.
-e
Встановити поле ідентифікації ECHO_REQUEST. Значення 0 неявно визначає використання сокета без обробки (його підтримку не передбачено для сокета датаграми ICMP). Значення поля може бути виведено з параметром -v.
-D
Вивести часову позначку (час unix + мікросекунди, як у gettimeofday) перед кожним рядком.
-f
Заповнювальне зондування. Для кожного надісланого ECHO_REQUEST буде виведено крапку «.», а для кожного отриманого ECHO_REPLY буде виведено символ забою (вилучення попереднього символу). Таким чином, можна швидко дізнатися про кількість пакунків, які було відкинуто. Якщо інтервал не вказано, буде встановлено нульовий інтервал і виведено пакети якомога швидше або сотню разів за секунду, якомога більше даних. Цим параметром із нульовим інтервалом може користуватися лише надкористувач.
-F мітка потоку
Лише IPv6. Розмістити і встановити 20-бітову мітку потоку (у шістнадцятковому форматі) для пакетів запиту щодо луна-сигналу. Якщо встановлено нульове значення, ядро розміщує випадкову мітку потоку.
-h
Показати довідку.
-i інтервал
Чекати інтервал секунд між надсиланнями пакетів. Можна використовувати дійсні числа із крапкою для відокремлення десяткової дробової частини (незалежно від роздільника у вашій локалі). Типовим очікуванням є, зазвичай, одна секунда між пакетами, або вимикання очікування у режимі заповнювального зондування. Встановлювати значення інтервалу, менше за 2 мс, може лише надкористувач.
-I інтерфейс
Значення аргументу інтерфейс є або адреса, або назва інтерфейсу, або назва VRF. Якщо інтерфейсом буде адреса, параметр встановлює вказану адресу інтерфейсу для адреси джерела. Якщо інтерфейсом буде назва інтерфейсу, вказаний інтерфейс буде встановлено як інтерфейс джерела. Якщо інтерфейсом буде назва VRF (віртуальної маршрутизації і переспрямовування), кожен пакет буде маршрутизовано за допомогою відповідної таблиці маршрутизації; у цьому випадку, параметр -I можна повторити для визначення адреси джерела. ЗАУВАЖЕННЯ: для IPv6 при виконанні зондування адреси із локальною для посилання областю видимості, можна скористатися специфікацією посилання (за допомогою «%»-позначення у призначенні або за допомогою цього параметра), але вона вже не є обов'язковою.
-l попереднє_завантаження
Якщо вказано попереднє_завантаження, ping надсилатиме вказану кількість пакетів, не очікуючи на відповідь. Значення попереднього завантаження, яке перевищує 3, може вибирати лише надкористувач.
-L
Придушити петлю трансляційних пакетів. Цей прапорець застосовується, лише якщо призначенням зондування є трансляційна адреса.
-m позначка
Скористатися позначкою для позначення вихідних пакетів. Корисно з багатьох причин у ядрі, зокрема використання маршрутизації за правилами для вибору певної обробки вихідних даних.
-M параметр_pmtudisc
Вибрати стратегію визначення MTU для шляху. Аргументом параметр_pmtudisc може бути або do (заборонити фрагментацію, навіть локально), або want (виконати виявлення PMTU, фрагментувати локально, якщо розмір пакета великий), або dont (не встановлювати прапорець DF).
-N параметр_nodeinfo
Лише IPv6. Надсилати запити щодо відомостей щодо вузла ICMPv6 (RFC4620), замість запиту луна-сигналу. Потрібна можливість CAP_NET_RAW.
help
Показати довідку щодо підтримки NI.
назва
Надіслати запит щодо назв вузлів.
ipv6
Надіслати запит щодо адрес IPv6. Передбачено декілька специфічних для IPv6 прапорців.
ipv6-global
Надіслати запит щодо адрес IPv6 загальної області видимості.
ipv6-sitelocal
Надіслати запит щодо адрес IPv6 локального місця.
ipv6-linklocal
Надіслати запит щодо адрес IPv6 локального посилання.
ipv6-all
Надіслати запит щодо адрес IPv6 на інших інтерфейсах.
ipv4
Надіслати запит щодо адрес IPv4. Передбачено один специфічний для IPv4 прапорець.
ipv4-all
Надіслати запит щодо адрес IPv4 на інших інтерфейсах.
subject-ipv6=адреса_ipv6
Адреса об'єкта IPv6.
subject-ipv4=адреса_ipv4
Адреса об'єкта IPv4.
subject-name=назва_вузла
Назва об'єкта. Якщо містить декілька крапок, буде використано повну назву домену.
subject-fqdn=назва_вузла
Назва об'єкта. Завжди буде використано повну назву домену.
-n
Лише числове виведення даних. Спроба пошуку символічних назв для адрес вузлів не виконуватиметься.
-O
Повідомляти про нештатні відповіді ECHO ICMP до надсилання наступного пакета. Корисно разом із часовою позначкою -D, щоб записувати виведені дані до діагностичного файла і шукати пропущені відповіді.
-p взірець
Ви можете вказати до 16 «доповнювальних» байтів для доповнення пакета, який ви надсилаєте. Корисно для діагностування проблем із даними у мережі. Наприклад, -p ff призведе до доповнення надісланого пакета логічними одиницями.
-q
Виведення без повідомлень. Нічого не буде виведено, окрім рядків резюме під час запуску і завершення обробки.
-Q tos
Встановити біти, які пов'язано із якістю обслуговування (Quality of Service) у датаграмах ICMP. Аргументом
tos може бути десяткове (лише
ping) або шістнадцяткове число.
У RFC2474 ці поля має бути оброблено як 8-бітові диференційовані служби (DS), що складається з таких компонентів: бітів 0-1 (2 нижчих бітів) окремих даних і бітів 2-7 (6 вищих бітів) диференційованої кодової точки служб (DSCP). У RFC2481 і RFC3168 біти 0-1 використано для ECN.
Історично (RFC1349, став застарілим після впровадження RFC2474), ці дані мало бути оброблено так: біт 0 (нижчий біт) зарезервовано (у поточній версії перевизначено як керування перевантаженням), біти 1-4 для типу служби і біти 5-7 (вищі біти) для пріоритетності.
-r
Обійти звичайні таблиці маршрутизації і надіслати дані безпосередньо до вузла в долученому інтерфейсі. Якщо вузол не перебуває у безпосередньо долученій мережі буде повернуто повідомлення про помилку. Цим параметром можна скористатися для зондування локального вузла через інтерфейс, який не має маршруту через нього, якщо також використано параметр -I.
-R
Лише ping. Записувати маршрут. Включає параметр RECORD_ROUTE до пакета ECHO_REQUEST і виводить буфер маршруту для повернутих пакетів. Зауважте, що у заголовку IP може міститися лише дев'ять таких маршрутів. Багато вузлів мережі ігнорують або відкидають цей параметр.
-s розмір_пакета
Вказує кількість байтів даних, які слід надіслати. Типовим значенням є 56, тобто 64 байтів даних ICMP при поєднанні із 8 байтами даних заголовка ICMP.
-S sndbuf
Встановити sndbuf буфера. Якщо не вказано, буде вибрано так, щоб розмір буфера не перевищував розміру одного пакета.
-t ttl
Лише ping. Встановити строк дії IP.
-T параметр часової позначки
Встановити особливі параметри часової позначки IP. Аргументом параметр часової позначки може бути tsonly (лише часові позначки), або tsandaddr (часові позначки і адреси), або tsprespec вузол1 [вузол2 [вузол3 [вузол4]]] (вивести часові позначки для попередньо визначених переходів).
-U
Вивести повну затримку користувач-користувач (застаріла поведінка). Зазвичай, ping виводить час проходження мережі, який може бути різним, наприклад, через помилки DNS.
-v
Режим докладного виведення. Не придушувати відповіді DUP при зондуванні трансляційної адреси.
-V
Вивести дані щодо версії і завершити роботу.
-w строк_дії
Вказати час очікування, у секундах, до виходу з ping, незалежно від того, скільки пакетів було надіслано або отримано. У цьому випадку ping не зупиняється після надсилання кількості пакетів, програма чекає на завершення строку_дії, або доки не буде отримано відповіді на кількість відповідей або якогось сповіщення про помилки з мережі.
-W час_очікування
Час очікування на відповідь, у секундах. Параметр впливає на час очікування, лише якщо немає відповідей. Якщо відповіді є ping очікує на два часи проходження сигналу (RTT). Можна використовувати дійсні числа із крапкою для відокремлення десяткової дробової частини (незалежно від роздільника у вашій локалі). 0 означає «нескінченний час очікування».
При використанні ping для локалізації помилок програму слід спочатку запустити на локальному вузлі для перевірки того, чи є працездатним локальний інтерфейс мережі. Далі, слід виконати зондування усе віддаленіших вузлів і шлюзів. Буде обчислено часи проходження та статистику щодо втрати пакетів. Якщо буде отримати дублікати пакетів, їх не буде включено в обчислення втрати пакетів, хоча час проходження цих пакетів буде використано для обчислення мінімального, середнього, максимального та стандартного відхилення часу проходження.
Стандартне відхилення вибірки (mdev), по суті, середнє відхилення часу проходження сигналу від середнього часу проходження сигналу. Чим більшим буде mdev, тим більшою є зміна часу проходження сигналу (з часом). Якщо розкид часу проходження сигналу є великим, ви матимете проблеми зі швидкістю при передаванні великих масивів даних (таке передавання, якщо говорити строго, є довшим, ніж потрібно, оскільки зміна часу проходження, врешті, спричиняє потребу в очікуванні підтвердження на боці надсилання даних) і низьку якість інтернет-телефонії.
Якщо було надіслано (і отримано) вказану кількість пакетів або якщо роботу програми було перервано сигналом SIGINT, буде виведено коротке резюме. Коротші поточні статистичні дані можна отримати без переривання процесу за допомогою сигналу SIGQUIT.
Якщо ping не отримує ніяких пакетів взагалі, програма завершує роботу з кодом 1. Якщо одночасно вказано кількість пакетів і строк дії, і отримано менше за кількість пакетів до завершення строку дії, програма також завершить роботу з кодом 1. Якщо станеться інша помилка, програма завершить роботу з кодом 2. Якщо помилки не станеться, кодом виходу буде 0. Таким чином, кодом виходу можна скористатися для визначення того, чи є вузол працездатним.
Цю програму призначено для використання у перевірках працездатності мережі, вимірюваннях та керуванні мережами. Через навантаження, яке програма здатна спричинити у мережі, не варто використовувати ping під час звичайної роботи системи або використовувати її в автоматизованих сценаріях.